– If you are not specify version under RIP configuration, the router will only send version 1, but receive version 1 and version2.
Cisco_RIP(config-router)# do sh ip pro
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 10 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 1 2
Serial1/0 1 1 2
Serial1/1 1 1 2
To send specific verison update, configure like below (Sending only RIPv1)
Cisco_RIP(config)# interface serial0/0
Cisco_RIP(config-if)# ip rip send version 1
Cisco_RIP(config-if)# ip rip receive version 1
or
Cisco_RIP(config)# interface serial0/0
Cisco_RIP(config-if)# ip rip send version 2
Cisco_RIP(config-if)# ip rip receive version2
To see activity of RIP protocol, do debug " debug ip rip." Below example will show
*Mar 1 02:15:56.911: RIP: build update entries
*Mar 1 02:15:56.911: subnet 10.2.0.0 metric 2
*Mar 1 02:15:56.911: network 13.0.0.0 metric 1
*Mar 1 02:15:56.915: network 23.0.0.0 metric 1
*Mar 1 02:16:06.675: RIP: received v2 update from 23.0.0.2 on Serial1/1
*Mar 1 02:16:06.679: 10.2.0.0/16 via 0.0.0.0 in 1 hops
*Mar 1 02:16:09.231: RIP: sending v1 update to 255.255.255.255 via Serial1/0 (13.0.0.3)
*Mar 1 02:16:09.231: RIP: build update entries
*Mar 1 02:16:09.231: network 10.0.0.0 metric 1
*Mar 1 02:16:09.235: network 23.0.0.0 metric 1
*Mar 1 02:16:16.603: RIP: sending v2 update to 224.0.0.9 via Serial1/1 (23.0.0.3)
*Mar 1 02:16:16.603: RIP: build update entries
*Mar 1 02:16:16.603: 10.3.0.0/16 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:16:16.607: 13.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar 1 02:16:22.591: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (10.3.0.3)
[ RIPv1 ]
Subnet will be advertised if neighbor has same length of prefix. For example.
R1 = Serial0/0 : 10.2.0.1/16, FastEthernet0/0 : 10.1.0.1/16
R2 = Serial0/0 : 10.2.0.2/16, FastEthernet0/0 : 10.3.0.1/16
Once RIP is enable, both router will see 10.1.x.x/16, 10.2.x.x/16 and 10.3.x.x/16 on the routing table.
However, below case won’t show 10.1.x.x/16 and 10.3.x.x/16 on the routing table.
R1 = Serial0/0 : 20.2.0.1/16, FastEthernet0/0 : 10.1.0.1/16
R2 = Serial0/0 : 20.2.0.2/16, FastEthernet0/0 : 10.3.0.1/16
[ RIPv2 ]
[ Timer ]
If link is remaining within 5 sec, how to setup RIP timer.
Cisco_RIP(config-router)# timers basic 1 3 0 3
1 = Interval between updates
3 = Invalid timer
0 = Hold timer
3 = Flush timer
** Of course it shold be applied on both routers
[ Controlling update ]
Using distribute-list commands, advertise only IP block you want to announce to peers. In this case the IP block is 3.0.0.0.
router rip
network 3.0.0.0
network 13.0.0.0
network 23.0.0.0
distribute-list prefix only_adv out
!
ip prefix-list only_adv seq 5 permit 3.0.0.0/8
[ Not update thru specific interface ]
router rip
passive-interface FastEthernet0/0
network 2.0.0.0
network 10.0.0.0
[ Unicast update ]
router rip
network 2.0.0.0
network 10.0.0.0
neighbor 10.0.0.1
[ Unicast update – RIPv2 ]
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
[ Summarization ]
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
ip summary-address rip 1.0.0.0 255.252.0.0
[ default origin ]
router rip
network 1.0.0.0
network 10.0.0.0
default-information originate