Shadow T1 service configuration for Adtran router

Shadow T1 Frame-relay service configuration for Adtran router

 The following BGP example configuration is for shadow T1 Frame-relay service with same ASN. In order to configure Adtran router, just copy and paste below configuration from configuraion mode

First neighbor ASN : 200
Neighbor IP address : 10.10.10.2

Second neighbor ASN : 200
Neighbor IP address : 20.20.20.2

All inbound/outbound traffic will be passed thru primary link until it get outage.

** Just for the education purpose, private IP block is used in this example

 

Adtran_Router#show configuration
Using 1127 bytes
!
hostname "Adtran_Router"
enable password adtran
!
clock timezone -3-Buenos-Aires
!
ip subnet-zero
ip classless
ip routing
!
auto-config
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption  
!
!
no ip firewall alg h323
!
!
interface eth 0/1
  ip address x.x.x.x 255.255.255.0
  no shutdown
  no lldp send-and-receive
!
interface t1 1/1
  tdm-group 1 timeslots 1-24 speed 64
  no shutdown
!
interface t1 1/2
  clock source through
  tdm-group 1 timeslots 1-24 speed 64  
  no shutdown
!
interface fr 1 point-to-point  
  frame-relay lmi-type ansi
  no shutdown
  cross-connect 1 t1 1/1 1 frame-relay 1
!
interface fr 1.500 point-to-point
  frame-relay interface-dlci 500
  ip address 10.10.10.1 255.255.255.252
  mtu 4470
  no lldp send-and-receive
!
interface fr 2 point-to-point
  frame-relay lmi-type ansi
  no shutdown
  cross-connect 2 t1 1/2 1 frame-relay 2
!
interface fr 2.500 point-to-point
  frame-relay interface-dlci 500
  ip address 20.20.20.1 255.255.255.252
  mtu 4470
  no lldp send-and-receive
!

route-map shadow permit 10
  set metric 20
route-map primary permit 10
  set metric 10
!
router bgp 100
  no auto-summary
  no synchronization
  network x.x.x.0 mask 255.255.255.0
  neighbor 10.10.10.2
    no default-originate
    route-map primary in
    route-map primary out
    soft-reconfiguration inbound
    remote-as 200

  neighbor 20.20.20.2
    no default-originate
    route-map shadow in
    route-map shadow out
    soft-reconfiguration inbound
    remote-as 200
!
ip route 192.168.1.0 255.255.255.0 null 0
no ip tftp server
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
line con 0  
  login
  password adtran
!
line telnet 0 4
  login
  password adtran
  line-timeout 30
  no shutdown
line ssh 0 4
  login local-userlist
  no shutdown
!
!
end
Adtran_Router#
 

Leave a Reply